NamelessMC

Internet Explorer

Internet Explorer is not supported. Please upgrade to a more modern browser.

Error Updating to 2.1.0
Started by Arkon

Arkon

Arkon

Member
Joined
08 Apr 2022
Last Seen
13 Mar 2024
Topics
2
Posts
3

There are 4 migrations files which have not been executed:

- 20220921014904_CreateMemberListsTable

- 20230121015140_AddAuthMeColumnsToUserTable

- 20230206192726_CreateQueueTable

- 20230302090631_AddImageColumnToPageDescriptionsTable

 

 

 

on every page. I put the files 2.1.0 and before clicking Update I came out this.

Arkon · 10 months ago · Last edited: 10 months ago
Samerton

Samerton

Owner
Joined
30 Mar 2015
Last Seen
19 Jun 2024
Topics
41
Posts
1064

Please visit yoursite.com/index.php?route=/panel/upgrade to run migrations

Samerton · 10 months ago
unitedfactions

unitedfactions

Member
Joined
26 Mar 2020
Last Seen
03 Jan 2024
Topics
0
Posts
2

Hey Samterton, running into the same issue. But although in previous upgrades /index.php?route=/panel/upgrade was always great in this version it does not work. Upgrading from release 203 to 210...

After doing the workaround of changing line L13 to L17 in upgrade.php
as suggested here by the Discord bot: https://github.com/NamelessMC/Nameless/blob/v2/modules/Core/pages/panel/upgrade.php#L13-L17

https://privatebin.net/?3d527d4b59906f52#2HvpnKHmmhKVfPokpTNHW5zPjzNgvZWTfYMCyj23q3BV

It still won't let me go to the upgrade page. Hence i even tried disabling friendly urls to run the upgrade but not luck.

Can you please respond? Apoligies for stealing the topic but this one comes up in Google when searching for this error.

unitedfactions · 6 months ago · Last edited: 6 months ago