NamelessMC

Internet Explorer

Internet Explorer is not supported. Please upgrade to a more modern browser.

Email error
Started by SpyCraft3r

SpyCraft3r

SpyCraft3r

Member
Joined
01 Mar 2024
Last Seen
31 May 2024
Topics
2
Posts
4

Please help, how can I fix this? I am trying to use my ISP to send verification email:

2024-03-28 10:21:50 Connection: opening to ssl://mail.optusnet.com.au:465, timeout=15, options=array()
2024-03-28 10:21:51 Connection failed. Error #2: stream_socket_client(): unable to connect to ssl://mail.optusnet.com.au:465 (Connection refused) [/home/annettej/straya.biz/vendor/phpmailer/phpmailer/src/SMTP.php line 397]
2024-03-28 10:21:51 SMTP ERROR: Failed to connect to server: Connection refused (111)
SMTP Error: Could not connect to SMTP host. Failed to connect to server

I have looked and can see no option "secure" in the php

Port 587 vs port 465

E-mail submission can use two protocols:

 

  • STARTTLS on port 587. In core/config.phpsecure should be set to tls (default).
  • Implicit TLS on port 465. In core/config.phpsecure should be set to ssl.

 

SpyCraft3r · 3 months ago · Last edited: 3 months ago
Samerton

Samerton

Owner
Joined
30 Mar 2015
Last Seen
17 Jun 2024
Topics
41
Posts
1064

I believe you can add secure into the email section of config.php manually if it is not already present, e.g.

<?php

...

'email' => [
  'host' => '',
  ...
  'secure' => 'tls',
],
x1
Samerton · 3 months ago
Yurkhun

Yurkhun

Member
Joined
29 May 2024
Last Seen
02 Jun 2024
Topics
0
Posts
1

thanks samerton this helped me, I added the line  secure in my config.php to 'ssl' and now my smtp is working fine 

x1
Yurkhun · 17 days ago